Utilizamos cookies propias y de terceros. Al navegar entendemos que aceptas el uso de cookies. +Info.
Política de cookies
Proyecto AjpdSoft

· Inicio
· Buscar
· Contactar
· Cookies
· Descargas
· Foros
· Historia
· Nosotros
· Temas
· Top 10
· Trucos
· Tutoriales
· Usuario
· Wiki

Proyecto AjpdSoft: Foros

AjpdSoft :: Ver tema - Delphi 5 - ORACLE 9i a 11g
Foros de discusión Buscar Perfil FAQ Iniciar sesión
Information Delphi 5 - ORACLE 9i a 11g

Publicar nuevo tema Responder al tema
Foros de discusión » Borland Delphi, Codegear Delphi .Net   
Ver tema anterior :: Ver tema siguiente
AutorMensaje
Izzy
Usuario


Registrado: Jan 26, 2010
Mensajes: 2

Asunto: Delphi 5 - ORACLE 9i a 11g Responder citando

Hola a todos,

Acabo de registrarme porque tengo un problema que no se por dónde pillarlo, y por los mensajes que he visto, creo que podréis ayudarme.

Tengo una aplicación en Delphi 5 que actualmente conecta con un ORACLE 9i a través de DBE v5.01. En la configuración del DBE para el Driver nativo de ORACLE está, entre otras cosas, lo siguiente:

VERSION: 4.0
TYPE: SERVER
DLL32: SQLORA8.DLL
VENDOR INIT: OCI.DLL
SERVER NAME: ORA_SERVER
SQLQRYMODE: SERVER

Con esto la conexión funciona correctamente al ejecutar el método "open" de un control DataBase del paquete DCLBDE50.

El tema es que tengo que sustituir el servidor por otro y se va a instalar la versión 11g de ORACLE, y con la configuración anterior no conecta a la base de datos 11g de pruebas que tengo aquí.

¿Alguien sabe qué tendría que hacer para que no tuviese que instalar un cliente ORACLE 11g en los equipos con esta aplicación? supongo que podré registrar alguna DLL que se pueda asociar al Driver ¿no?

¿Qué se os ocurre que puedo hacer?

Muchas gracias por adelantado.
MensajePublicado:
Mar Ene 26, 2010 11:54 am
Top of PageVer perfil de usuario
Jonalux
Usuario


Registrado: Mar 09, 2010
Mensajes: 2

Asunto: Responder citando

Yo tengo el mismo problema, si alguien sabe cual es la solución, que la postee por favor, se agredecera.
MensajePublicado:
Mar Mar 09, 2010 8:24 am
Top of PageVer perfil de usuario
Izzy
Usuario


Registrado: Jan 26, 2010
Mensajes: 2

Asunto: Responder citando

Lo cierto es que en mi caso el problema se debía a que el usuario y la clave de usuario de acceso a base de datos se toma de un archivo de configuración en el que estos dos datos estaban en mayúsculas, y la versión 11 de ORACLE hace distinción entre mayúsculas y minúsculas en la clave de usuario, cosa que no hace ORACLE 9.

No se si será lo mismo que te pasa a tí, pero por si acaso, revísalo.

Un saludo.
MensajePublicado:
Mar Mar 09, 2010 9:45 am
Top of PageVer perfil de usuario
Jonalux
Usuario


Registrado: Mar 09, 2010
Mensajes: 2

Asunto: Responder citando

Gracias por contestar.

Pero mi problemas al final fue porque no estaba fisicamente el fichero DLL en la maquina.

Lo solucione instalando un nuevo BDE que venia con esas librerias.
MensajePublicado:
Jue Mar 11, 2010 8:32 am
Top of PageVer perfil de usuario
Mostrar mensajes de anteriores:   
Todas las horas son GMT - 1 Horas
Publicar nuevo tema Responder al tema
Foros de discusión » Borland Delphi, Codegear Delphi .Net  

Cambiar a:  
Key
  Puede publicar nuevos temas en este foro
No puede responder a temas en este foro
No puede editar sus mensajes en este foro
No puede borrar sus mensajes en este foro
No puede votar en encuestas en este foro
Visita nuestro nuevo sitio web con programas y contenidos actualizados: Proyecto A