Utilizamos cookies propias y de terceros. Al navegar entendemos que aceptas el uso de cookies. +Info.
Política de cookies
Proyecto AjpdSoft

· Inicio
· Buscar
· Contactar
· Cookies
· Descargas
· Foros
· Historia
· Nosotros
· Temas
· Top 10
· Trucos
· Tutoriales
· Usuario
· Wiki

Proyecto AjpdSoft: Foros

AjpdSoft :: Ver tema - Instalación DevExpress QuantumGrid 6.30 en Delphi 6
Foros de discusión Buscar Perfil FAQ Iniciar sesión
Information Instalación DevExpress QuantumGrid 6.30 en Delphi 6

Publicar nuevo tema Responder al tema
Foros de discusión » Borland Delphi, Codegear Delphi .Net   
Ver tema anterior :: Ver tema siguiente
AutorMensaje
varios
Magnífico usuario


Registrado: Oct 10, 2006
Mensajes: 2092

Asunto: Instalación DevExpress QuantumGrid 6.30 en Delphi 6 Responder citando

Estoy intentando instalar DevExpress QuantumGrid 6.30 en Borland Delphi 6.0, pero me da varios errores, uno de ellos:

[Error] cxVariants.pas(334): Undeclared identifier: 'FindVarData'
[Error] cxVariants.pas(334): Pointer type required
[Error] cxVariants.pas(341): Undeclared identifier: 'FindVarData'
[Error] cxVariants.pas(341): Pointer type required
[Error] cxVariants.pas(341): 'END' expected but ')' found
[Fatal Error] cxCustomData.pas(43): Could not compile used unit 'cxVariants.pas'


He buscado por ahí y he añadido esta función a la unidad cxVariants.pas:

Código:

function FindVarData(const V: Variant): PVarData;
begin
  Result := @TVarData(V);
  while Result.VType = varByRef or varVariant do
    Result := PVarData(Result.VPointer);
end;


Pero al compilar me aparece este otro error:

cxExtEditConsts.pas(121) Error: Undeclared identifier: 'clHotLight'

No consigo instalar DevExpress QuantumGrid 6.30 en Borland Delphi 6.0.
MensajePublicado:
Jue Abr 16, 2009 5:19 pm
Top of PageVer perfil de usuario
alonsojpd
Administrador/Moderador


Registrado: Sep 16, 2003
Mensajes: 2687

Asunto: Re: Instalación DevExpress QuantumGrid 6.30 en Delphi 6 Responder citando



Anuncios



varios escribió:
Estoy intentando instalar DevExpress QuantumGrid 6.30 en Borland Delphi 6.0, pero me da varios errores, uno de ellos:

[Error] cxVariants.pas(334): Undeclared identifier: 'FindVarData'
[Error] cxVariants.pas(334): Pointer type required
[Error] cxVariants.pas(341): Undeclared identifier: 'FindVarData'
[Error] cxVariants.pas(341): Pointer type required
[Error] cxVariants.pas(341): 'END' expected but ')' found
[Fatal Error] cxCustomData.pas(43): Could not compile used unit 'cxVariants.pas'


He buscado por ahí y he añadido esta función a la unidad cxVariants.pas:

Código:

function FindVarData(const V: Variant): PVarData;
begin
  Result := @TVarData(V);
  while Result.VType = varByRef or varVariant do
    Result := PVarData(Result.VPointer);
end;


Pero al compilar me aparece este otro error:

cxExtEditConsts.pas(121) Error: Undeclared identifier: 'clHotLight'

No consigo instalar DevExpress QuantumGrid 6.30 en Borland Delphi 6.0.



Estos errores se deben a que DevExpress QuantumGrid 6.30 requiere que tengas instalado Delphi 6 Update Pack 2, que es un parche para Delphi 6, lo tienes disponible en la web:

http://edn.embarcadero.com/article/38607
MensajePublicado:
Jue Abr 16, 2009 5:26 pm
Top of PageVer perfil de usuario
varios
Magnífico usuario


Registrado: Oct 10, 2006
Mensajes: 2092

Asunto: Re: Instalación DevExpress QuantumGrid 6.30 en Delphi 6 Responder citando



Anuncios



alonsojpd escribió:

Estos errores se deben a que DevExpress QuantumGrid 6.30 requiere que tengas instalado Delphi 6 Update Pack 2, que es un parche para Delphi 6, lo tienes disponible en la web:

http://edn.embarcadero.com/article/38607


He instalado el Delphi 6 Update Pack 2 y al compilar una aplicación de las que tenía antes de instalar este parche me aparece este error:

[Fatal Error] Conversor.dpr(7): Unit Variants was compiled with a different version of SysConst.SVarTypeCouldNotConvert

¿cómo puedo arreglarlo? ¿tengo que cambiar algo en el código fuente? esto sería complicado pues tengo muchas apliacaciones con Delphi 6 sin el Update Pack 2.
MensajePublicado:
Jue Abr 16, 2009 5:41 pm
Top of PageVer perfil de usuario
alonsojpd
Administrador/Moderador


Registrado: Sep 16, 2003
Mensajes: 2687

Asunto: Re: Instalación DevExpress QuantumGrid 6.30 en Delphi 6 Responder citando



Anuncios



varios escribió:
He instalado el Delphi 6 Update Pack 2 y al compilar una aplicación de las que tenía antes de instalar este parche me aparece este error:

[Fatal Error] Conversor.dpr(7): Unit Variants was compiled with a different version of SysConst.SVarTypeCouldNotConvert

¿cómo puedo arreglarlo? ¿tengo que cambiar algo en el código fuente? esto sería complicado pues tengo muchas apliacaciones con Delphi 6 sin el Update Pack 2.


Elimina todos los ficheros de extensión .dcu que tengas en el proyecto que estás compilando, luego pulsa en el menú "Project" - "Compile All Projects" y luego "Project" - "Build All Projects". Con esto no tendrás que modificar nada en el código fuente para que te funcionen las aplicaciones que tengas en Borland Delphi 6 con Update Pack 2.
MensajePublicado:
Jue Abr 16, 2009 5:45 pm
Top of PageVer perfil de usuario
Mostrar mensajes de anteriores:   
Todas las horas son GMT - 1 Horas
Publicar nuevo tema Responder al tema
Foros de discusión » Borland Delphi, Codegear Delphi .Net  

Cambiar a:  
Key
  Puede publicar nuevos temas en este foro
No puede responder a temas en este foro
No puede editar sus mensajes en este foro
No puede borrar sus mensajes en este foro
No puede votar en encuestas en este foro
Visita nuestro nuevo sitio web con programas y contenidos actualizados: Proyecto A