Utilizamos cookies propias y de terceros. Al navegar entendemos que aceptas el uso de cookies. +Info.
Política de cookies
Proyecto AjpdSoft

· Inicio
· Buscar
· Contactar
· Cookies
· Descargas
· Foros
· Historia
· Nosotros
· Temas
· Top 10
· Trucos
· Tutoriales
· Usuario
· Wiki

Proyecto AjpdSoft: Foros

AjpdSoft :: Ver tema - Error SDK Build Tools revision xxx is too low for project
Foros de discusión Buscar Perfil FAQ Iniciar sesión
Information Error SDK Build Tools revision xxx is too low for project

Publicar nuevo tema Responder al tema
Foros de discusión » Android, Java, software para smartphones   
Ver tema anterior :: Ver tema siguiente
AutorMensaje
varios
Magnífico usuario


Registrado: Oct 10, 2006
Mensajes: 2092

Asunto: Error SDK Build Tools revision xxx is too low for project Responder citando

Hola, estoy intentando iniciarme en el desarrollo de aplicaciones para móviles, en concreto para Android, estoy usando Android Studio, me inicié siguiendo vuestro videotutorial:



El caso es que tenía una App empezada que dejé a medias hace un tiempo, ahora al abrirla con Android Studio me aparece este error:

Error:The SDK Build Tools revision (19.0.3) is too low for project ':app'. Minimum required is 19.1.0

Mirando el log indica:

2015-05-15 12:37:09,394 [3008719] WARN - .project.GradleProjectImporter -
2015-05-15 12:37:09,394 [3008719] INFO - .project.GradleProjectImporter - The SDK Build Tools revision (19.0.3) is too low for project ':app'. Minimum required is 19.1.0
Consult IDE log for more details (Help | Show Log)
2015-05-15 12:38:32,020 [3091345] INFO - api.vfs.impl.local.FileWatcher - Change requests:16384, filtered:6345


No tengo conocimientos y no sé a qué se refiere el error, agradezco cualquier ayuda.
MensajePublicado:
Vie May 15, 2015 9:43 am
Top of PageVer perfil de usuario
alonsojpd
Administrador/Moderador


Registrado: Sep 16, 2003
Mensajes: 2687

Asunto: Re: Error SDK Build Tools revision xxx is too low for projec Responder citando



Anuncios



varios escribió:
El caso es que tenía una App empezada que dejé a medias hace un tiempo, ahora al abrirla con Android Studio me aparece este error:

Error:The SDK Build Tools revision (19.0.3) is too low for project ':app'. Minimum required is 19.1.0


El error que nos comentas suele ser debido a que tu aplicación necesita el "Android SDK Build-tools" en su versión 19.1.0, por lo tanto debes instalarlo desde Android Studio, en el menú "Tools" - "Android" - "SDK Manager", en la ventana de Android SDK Manager marcas el paquete "Android SDK Build-tools" de la versión que te indica que requieres (está en la rama "Tools") y pulsas en "Install packages".


Ultima edición por alonsojpd el Vie May 15, 2015 10:28 am, editado 1 vez
MensajePublicado:
Vie May 15, 2015 9:48 am
Top of PageVer perfil de usuario
alonsojpd
Administrador/Moderador


Registrado: Sep 16, 2003
Mensajes: 2687

Asunto: Re: Error SDK Build Tools revision xxx is too low for projec Responder citando



Anuncios



Además de lo que te hemos comentado anteriormente, el contenido del fichero build.gradle del proyecto Android Studio debe ser algo así:

Código:

apply plugin: 'android'

android {
    compileSdkVersion 19
    buildToolsVersion "19.1.0"

    defaultConfig {
        minSdkVersion 15
        targetSdkVersion 19
    }

    buildTypes {
        release {
            runProguard false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
        }
    }
}
MensajePublicado:
Vie May 15, 2015 10:27 am
Top of PageVer perfil de usuario
Mostrar mensajes de anteriores:   
Todas las horas son GMT - 1 Horas
Publicar nuevo tema Responder al tema
Foros de discusión » Android, Java, software para smartphones  

Cambiar a:  
Key
  Puede publicar nuevos temas en este foro
No puede responder a temas en este foro
No puede editar sus mensajes en este foro
No puede borrar sus mensajes en este foro
No puede votar en encuestas en este foro
Este sitio web NO CONTIENE malware, todos los programas con código fuente aquí. Autor: Alonso Javier Pérez Díaz Google+ Síguenos en Google+